Major Outage
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 17:38 EDT
Monitoring
Large scale outages amongst one or more of our service providers have resulted in increased load times and decreased functionality across Teachable's platform. Our development team is closely monitoring the situation. We will provide updates as soon as they become available.
Posted Jul 17, 2020 - 17:27 EDT