Investigating login issues on some schools
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Feb 27, 2020 - 18:08 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2020 - 17:42 EST
Investigating
Our engineering team is investigating the source of login issues impacting some of our Teachable schools

We will provide an update as soon as there's additional information available.
Posted Feb 27, 2020 - 17:35 EST
This incident affected: Student View.