Students in localized regions are unable to watch content videos
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted May 22, 2021 - 10:00 EDT
Investigating
We are currently investigating content video outages.
Posted May 22, 2021 - 09:07 EDT
This incident affected: Student View.