Temporary Disruption in Service

Incident Report for Teachable

Resolved

As of around 12:30 EST the service disruption was resolved. All systems are operational.
Posted Jun 02, 2025 - 17:29 EDT

Monitoring

A fix has been implemented to normalize feature access after a temporary disruption which started at 9:30AM EST for some customers. The team is continuing to monitor to ensure the issue is resolved.
Posted Jun 02, 2025 - 12:00 EDT

Identified

The team is monitoring a disruption in service starting at 9:30AM EST impacting some customer's ability to access certain features in their school admin. They've deployed a fix and are monitoring to ensure the issue is resolved.
Posted Jun 02, 2025 - 10:53 EDT
This incident affected: Managing your School (Product Administration).