Slight Payout Delay for Teachable Monthly Gateway Users
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted May 01, 2024 - 18:09 EDT
Monitoring
Due to an unforeseen earlier issue reported by PayPal, creators using Teachable's Monthly Payment Gateway are now expected to receive their scheduled payouts within the next two hours. We understand the importance of this situation and can assure you PayPal's team worked quickly to resolve the issue.
Posted May 01, 2024 - 11:44 EDT
This incident affected: teachable.com and Accepting & Processing Payments (Monthly Payment Gateway).