This incident has been resolved. We apologize for any inconvenience this may have caused and thank you for your patience.
Posted Sep 04, 2024 - 13:59 EDT
Identified
Identified - We've identified a delay in payouts for some customers leveraging Teachable Payment Gateway due to a possible issue with Stripe. These payouts were originally scheduled for 9AM EST, Wednesday, September 4th. Our team is actively working to resolve this issue and deploy a fix so payouts are delivered as quickly as possible. We understand the importance of this situation and are taking it very seriously. We'll share an update as soon as possible.
Posted Sep 04, 2024 - 10:04 EDT
Monitoring
Identified - We've identified a delay in payouts for creators leveraging Teachable Payment Gateway. These payouts were originally scheduled for Tuesday September 3rd, 2024. Our team is actively working to resolve this issue and deploy a fix so creators' payouts are delivered as quickly as possible. We understand the importance of this situation and are taking it very seriously. We'll share an update as soon as possible.