The scheduled database maintenance has been completed successfully. All services are now back online and operating normally.
Thank you for your patience during the maintenance window. Please reach out if you notice any unexpected behavior.
Posted Jun 15, 2025 - 07:26 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 15, 2025 - 07:00 EDT
Scheduled
We will be performing routine database maintenance during this window. As part of the process, services will be progressively restarted, which may result in brief periods of unavailability across parts of the application. We appreciate your patience and understanding.
Posted Jun 13, 2025 - 16:52 EDT
This scheduled maintenance affected: Account (Log In, Google SSO, Teachable Accounts), Student Experience (Checkout, Content Delivery), and developers.teachable.com.