Our video player on Creator Pages is experiencing outages

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted May 03, 2022 - 11:17 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 03, 2022 - 10:30 EDT

Investigating

We are currently experiencing outages with our video player component on our creator sales pages. Our users may not see any player.
Posted May 03, 2022 - 10:13 EDT