Notice of a Stripe payout delay on November 5th, 2025 (teachable:pay)

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 08:29 EST

Monitoring

This morning, we received a notice from Stripe that some teachable:pay earnings scheduled to land in connected bank accounts on November 5th, 2025 experienced a slight delay in delivery. As of today, November 6th, all applicable funds have been deposited to your bank account.

Stripe has resolved the underlying issue that caused this delay and there is no action needed from you. We expect all future payouts to be delivered to your bank account as expected. We apologize for this delay and any inconvenience. Please reach out to our Support team with further questions.
Posted Nov 06, 2025 - 12:47 EST
This incident affected: Accepting & Processing Payments (teachable:pay).