Paypal Transaction Disruption
Incident Report for Teachable
Resolved
Our team has now issued refunds of the overcharged amounts to all impacted student purchasers. Students should see those funds in their PayPal account within the next 48 hours. In addition, all impacted students and creators have now received relevant details of the incident and their refund via email. We thank those impacted for their patience, and apologize for the concern this may have caused.
Posted Aug 07, 2024 - 15:29 EDT
Update
Our team has confirmed yesterday's issue impacted only a small subset of students purchasing from Teachable creators via PayPal. Those affected students and creators are actively being notified and will receive an email from our team by close of business today. Student purchasers can expect to see the full refund of the overcharged amount in their PayPal account within 48 hours. We understand the seriousness of this issue, and our team worked as quickly as possible to deploy a fix and halt any further PayPal charge inaccuracies.
Posted Aug 07, 2024 - 11:19 EDT
Monitoring
Our team has resolved the immediate issue causing incorrect billing amounts to be processed with PayPal. We're actively working on correcting the affected transactions and will be in touch with impacted customers. We recognize the urgency of this matter and will continue to provide updates until it's resolved.
Posted Aug 06, 2024 - 20:31 EDT
Identified
We’ve identified an issue preventing Teachable’s paypal transactions from processing properly for students. Our team is in the process of deploying a fix and expect this to be resolved shortly. We apologize for the inconvenience and thank you for your patience.
Posted Aug 06, 2024 - 18:24 EDT
This incident affected: Accepting & Processing Payments (Monthly Payment Gateway, teachable:pay).