Partial Platform Outage

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 11:39 EST

Monitoring

Our team had identified an issue that may have resulted in partial platform outages on the student experience for both mobile and desktop. We understand the urgency of resolving this issue and we apologize for the inconvenience. Thank you for your patience, and please check back here for an update shortly.
Posted Jan 08, 2026 - 07:15 EST
This incident affected: Student Experience (Content Delivery, iOS Application, Video Playback).