Delay in payouts for some creators using Teachable's Payment gateway
Incident Report for Teachable
Resolved
We've confirmed that the delay is resolved and creators using Teachable Pay are receiving payouts on time. Thank you for your patience
Posted Nov 26, 2024 - 11:03 EST
Monitoring
We've identified a 12-hour delay in payouts for some creators leveraging Teachable's Payment Gateway. Our team has implemented a fix and is actively monitoring the next 24 hours to ensure a successful resolution. We understand the importance of this situation and are taking it very seriously. We'll share an update as soon as possible.
Posted Nov 25, 2024 - 17:28 EST
This incident affected: Accepting & Processing Payments (teachable:pay).