Downloads and Coaching are inaccessible

Incident Report for Teachable

Resolved

Our team has resolved an issue resulting in coaching and downloads not being accessible for students. We apologize for the disruption and thank you for your patience.
Posted Feb 05, 2026 - 21:54 EST

Identified

The issue has been identified and our team is in the process of deploying a fix and expect this to be resolved shortly. We apologize for the inconvenience and thank you for your patience.
Posted Feb 05, 2026 - 21:00 EST

Investigating

Our team has identified an issue resulting in the inability to access coaching and downloadable products. We understand the critical urgency of resolving this issue and we apologize for the inconvenience. Thank you for your patience, and please check back here for an update shortly.
Posted Feb 05, 2026 - 20:27 EST