Payout interruption
Incident Report for Teachable
Resolved
Resolved - Our team has resolved the payouts for creators leveraging Teachable's Payment Gateway. Payouts originally scheduled for June 11 2024 and June 12 2024 have been successfully transferred from Teachable to respective creator Stripe accounts as of 22:00 AM/PM ET on June, 12, 2024. Payouts scheduling will resume as expected moving forward.
Posted Jun 14, 2024 - 11:56 EDT
Monitoring
Payouts to Stripe Express accounts initially scheduled for June 11, 2024, will resume shortly. Additionally, payouts scheduled for today, June 12, 2024, will also resume soon. Thank you for your patience and understanding as we worked as quickly as possible to restore normal payout operations. For further information or support, please contact our Support team.
Posted Jun 12, 2024 - 17:35 EDT
Identified
We've identified a delay in payouts for creators leveraging Teachable's Daily payouts on teachable:pay. These payouts were originally scheduled for 5pm EST, June 11, 2024. Our team is actively working to resolve this issue and deploy a fix so creators' payouts are delivered as quickly as possible. We understand the importance of this situation and are taking it very seriously. We'll be sharing updates daily until we have resolution.
Posted Jun 11, 2024 - 18:17 EDT
This incident affected: Accepting & Processing Payments (teachable:pay).