Admin-level users unable to access and view student information
Incident Report for Teachable
Resolved
Our team has resolved the issue preventing Teachable’s Student Info pages from loading. We thank you for your patience as our team worked as quickly as possible to resolve the situation.
Posted Nov 20, 2024 - 16:03 EST
Identified
We’ve identified an issue preventing Teachable’s Student Info page from loading properly for creators. Our team is in the process of deploying a fix and expect this to be resolved shortly.
Posted Nov 20, 2024 - 15:50 EST
This incident affected: Managing your School (User Management).