myT users experiencing problems creating new schools
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Dec 17, 2020 - 10:04 EST
Update
Incident has been resolved
Posted Dec 17, 2020 - 10:02 EST
Update
We have identified the cause of the issue and are working on a fix
Posted Dec 17, 2020 - 09:39 EST
Investigating
We are currently investigating
Posted Dec 17, 2020 - 09:24 EST
This incident affected: Admin Panel.