Teachable's support software, Intercom, is experiencing an outage

Incident Report for Teachable

Resolved

This is now resolved
Posted Jan 09, 2026 - 16:24 EST

Monitoring

Our support software partner, Intercom, recently posted a status page communicating it's experiencing an outage. As a result, some Teachable customers may have issues communicating with our Support team. We'll continue to monitor Intercom's status and will provide updates. For more information please visit https://www.intercomstatus.com/us-hosting. Thank you for your patience.
Posted Jan 09, 2026 - 15:09 EST