Teachable Homepage is currently not resolving

Incident Report for Teachable

Resolved

The incident has been resolved. Traffic to teachable.com has resumed.
Posted Aug 30, 2022 - 18:18 EDT

Investigating

Teachable's Homepage is unable to be resolved.

Our core product remains accessible and students and content creators may continue to use our product as expected.
Posted Aug 30, 2022 - 17:51 EDT