Payout Delay

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 10:51 EDT

Monitoring

We have identified a delay in earnings payouts from Teachable to creators' connected Stripe Express accounts on teachable:pay. Outstanding earnings will be paid out to creator's connected Stripe express accounts between 5pm EST and 8pm EST.
Posted Apr 14, 2025 - 20:28 EDT

Identified

We have identified a delay in earnings payouts from Teachable to creators' connected Stripe Express accounts on teachable:pay. Outstanding earnings will be paid out to creator's connected Stripe express accounts between 5pm EST and 8pm EST.
Posted Apr 14, 2025 - 17:18 EDT