Incorrect lecture videos playing

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted Sep 26, 2022 - 18:37 EDT

Monitoring

A solution has been deployed, we're monitoring the fix now.
Posted Sep 26, 2022 - 18:26 EDT

Investigating

We are currently investigating reports of incorrect lecture videos playing in some Teachable courses
Posted Sep 26, 2022 - 17:48 EDT