Bulk importing users for School Admins is temporarily disabled
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Jan 21, 2021 - 12:01 EST
Monitoring
We've temporarily disabling Bulk Importing Users in School Admin. Thank you for your patience.
Posted Jan 20, 2021 - 15:27 EST
This incident affected: Admin Panel.