Video Playback Issues Related to Video Player Partner Outage

Incident Report for Teachable

Update

We’ve identified intermittent video playback issues primarily impacting customers in Singapore. We’re actively working with their technical support team and will share updates as more information becomes available.
Posted Jan 16, 2026 - 11:48 EST

Identified

We’re currently experiencing video playback issues due to an outage affecting our video player partner in certain geographic regions. We’re actively working with their technical support team and will share updates as more information becomes available.
Posted Jan 16, 2026 - 11:12 EST
This incident affects: Student Experience (Video Playback).