Unusually High Processing Queue

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted Apr 16, 2024 - 10:57 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2024 - 08:17 EDT

Investigating

We're experiencing unusually high processing queue latency, which may lead to certain actions like course duplication, CSS changes, and sales notifications taking longer to reflect. We're monitoring and response times are trending towards normal. We expect that all jobs initiated during this latency will process as the queue clears.
Posted Apr 16, 2024 - 07:35 EDT
This incident affected: teachable.com and Managing your School (Video Uploading).