Experiencing elevated errors and degraded performance

Incident Report for Teachable

Monitoring

A fix has been deployed, and we're currently monitoring the results to ensure everything is working as expected. Thank you for your patience.
Posted Mar 31, 2026 - 16:29 EDT

Identified

Our team has identified an issue leading to intermittent unavailability, as well as slow load times across the platform. We are actively working to resolve this issue and deploy a fix as quickly as possible. We apologize for the inconvenience and thank you for your patience.
Posted Mar 31, 2026 - 15:33 EDT

Investigating

Our team has identified an issue leading to intermittent unavailability, as well as slow load times across the platform. We are actively working to resolve this issue and deploy a fix as quickly as possible. We apologize for the inconvenience and thank you for your patience.
Posted Mar 31, 2026 - 14:22 EDT