Partial Platform Outage

Incident Report for Teachable

Resolved

This incident has been resolved
Posted Feb 28, 2025 - 18:10 EST

Monitoring

We're monitoring an issue that impacted some schools and students who could not utilize some features on our paid plans.
Timeline of events:
-12 pm EST, impacted schools reported issues accessing certain features tied to paid plans. Issues prevented access for both the school owner and students.
~2 pm EST, student facing access was restored for all schools
~4 pm EST, school facing access was restored for all schools
Posted Feb 28, 2025 - 16:18 EST

Update

Update: Student purchasing and access is restored. Creator permissions are partially restored and the team is investigating remaining mismatches between plan features and access within the admin portal.
Posted Feb 28, 2025 - 15:06 EST

Identified

Update - We're working to resolve the ongoing incident
Posted Feb 28, 2025 - 14:40 EST

Update

We're investigating outages across our platform resulting in loss of plan features and user role permissions. This impacts both creators and students. We'll update as we identify and fix the problem.
Posted Feb 28, 2025 - 13:38 EST

Update

We are currently seeing partial or complete outages throughout out platformWe're investigating outages across our platform resulting in loss of plan features and user role permissions. This impacts both creators and students. We'll update as we identify and fix the problem.
Posted Feb 28, 2025 - 13:36 EST

Investigating

Users with custom roles may experience issues loading school admin or courses
Posted Feb 28, 2025 - 13:14 EST
This incident affected: Student Experience (Checkout, Circle Community, Content Delivery, iOS Application, Video Playback, Community) and Managing your School (Affiliates, Coaching, Course Building, Digital Downloads, Memberships, Product Administration, Product Bundles, Reporting, Styling your School, User Management, Video Uploading).