We’ve mitigated the downstream impacts from the AWS outage yesterday. We will continue to actively monitor our services and provide updates if anything changes.
Posted Oct 21, 2025 - 10:09 EDT
Monitoring
We've implemented a workaround to bring our student experience back online. Both admin and student facing services are restored. With the many downstream impacts of today's AWS outage, we're monitoring our admin and student facing experiences overnight and will provide another update before noon EST on 10/21.
Posted Oct 20, 2025 - 23:02 EDT
Investigating
Student facing pages may be slow or unavailable due to downstream impacts of AWS outage. Our team is investigating workarounds. Will provide updates as soon as we have more information.
Posted Oct 20, 2025 - 22:24 EDT
Identified
Admin and student facing pages may be slow or temporarily unavailable due to the AWS outage. Our team is monitoring the situation closely. We’ll provide updates as soon as we have more information.
Posted Oct 20, 2025 - 15:59 EDT
Update
We continue to observe intermittent instability affecting parts of the platform.
Student-Facing Services: - Purchasing courses and other products is operational. - Access to courses and other products for existing students is operational. - We’re investigating an issue impacting certificate downloads. - We’re investigating an issue where some students aren’t receiving login confirmation codes.
Creator-Facing Services - teachable.com is operational, and creators can log in normally. - Our live chat support platform is currently inaccessible. Please email support@teachable.com for urgent inquiries. - We’re aware of an issue where newly uploaded videos remain in a continuous “processing” state. We’re awaiting updates from our video transcoding provider and will share more information as soon as it becomes available.
Our team is actively monitoring all systems and working with our partners to restore full stability. We appreciate your understanding.
Posted Oct 20, 2025 - 15:17 EDT
Update
Our live chat support platform is currently inaccessible. Please email support@teachable.com for urgent inquiries. We appreciate your patience during this period of support downtime.
Posted Oct 20, 2025 - 12:19 EDT
Update
The teachable.com site continues to have access errors. As a workaround, anyone needing to sign into the Teachable platform can use the direct link below:
Our most recent update regarding system status continues to hold true.
Posted Oct 20, 2025 - 11:37 EDT
Monitoring
We're continuing to monitor and address the impact of today's AWS outage.
At this time, all student-facing services are fully operational, and our team continues to actively monitor system performance. School plan purchases, upgrades, and downgrades have been successfully restored and are functioning as expected.
We’re aware of an issue affecting video processing for newly uploaded videos and are working with our video service provider to address this.
Posted Oct 20, 2025 - 11:16 EDT
Identified
We've identified a problem related to plan updates for Teachable school plan customers. New subscriptions, upgrades, and downgrades aren't being correctly reflected within Teachable schools at the moment.
All student-facing services continue to operate normally and our team is closely monitoring for other AWS outage impacts.
Posted Oct 20, 2025 - 10:27 EDT
Monitoring
Our services have been restored and are operating normally. AWS continues to report partial outages, and our team is closely monitoring. Thank you for your patience and understanding.
Posted Oct 20, 2025 - 09:40 EDT
Update
The teachable.com site is undergoing a DNS update preventing access to our marketing frontpage. To log into Teachable accounts, use the direct link below:
We’re currently experiencing downtime due to a broader AWS outage. We will provide updates as more information becomes available from AWS. We appreciate your understanding.
Posted Oct 20, 2025 - 04:51 EDT
Identified
We’re currently experiencing downtime due to a broader AWS outage. We will provide updates as more information becomes available from AWS. We appreciate your understanding.
Posted Oct 20, 2025 - 04:48 EDT
Investigating
Our team has identified an issue that is impacting our platform. Thank you for your patience while we investigate.