PDFs showing incorrect placeholder document

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 17:36 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2026 - 17:05 EDT

Identified

We've identified an issue causing file previews to display an incorrect placeholder document rather than the uploaded file. Our team is actively investigating and we'll post an update as soon as we have more information.
Posted Jun 16, 2026 - 15:59 EDT