This incident is now resolved. Customers are now able to complete their purchases normally, and we are seeing successful transactions.
Posted Aug 29, 2026 - 17:17 EDT
Monitoring
We’ve identified and implemented a fix for the issue affecting purchases through Teachable Checkout. Checkout functionality has been restored, and customers should now be able to complete their purchases normally.
Posted Aug 29, 2026 - 16:35 EDT
Identified
Fix identified for checkout issues.
We’ve identified the cause of the checkout issue and have a fix in progress. Our team is actively working to implement the solution and restore normal checkout functionality as quickly as possible. We’ll share another update once the fix is in place.
Posted Aug 29, 2026 - 14:17 EDT
Investigating
We’re currently investigating reports of customers being unable to complete purchases through Teachable checkout. Some customers may see a “Failed to fetch” error when attempting to make a payment.
Our team is actively investigating the issue and working to restore normal checkout functionality as quickly as possible. We’ll share another update as soon as we have more information.
Posted Aug 29, 2026 - 14:05 EDT
This incident affected: teachable.com and Accepting & Processing Payments (Custom Payment Gateway, Monthly Payment Gateway, teachable:pay).