Teachable:pay payout reporting inconsistencies

Incident Report for Teachable

Monitoring

We have resolved the issue impacting payout reporting and new payouts will appear in your Sales > Payouts menu as expected.

Our team is working to update the reporting to reflect impacted payouts that took place between 1/29 and 02/03.
Posted Feb 03, 2026 - 12:49 EST

Investigating

We have identified an inconsistency in teachable:pay payouts reporting between the Teachable Admin 'Payouts' page and your Stripe Express account. There has been no impact to the actual flow of funds.

For the most up-to-date reporting on your payouts, please navigate directly to your Stripe Express account while we resolve this issue.
Posted Feb 02, 2026 - 17:45 EST
This incident affects: Managing your School (Reporting).