Issues with school owners updating their billing information
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Feb 04, 2020 - 16:57 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 04, 2020 - 16:48 EST
Update
We are continuing to investigate this issue.
Posted Feb 04, 2020 - 16:44 EST
Investigating
This is not impacting students. We are currently investigating this issue.
Posted Feb 04, 2020 - 16:44 EST
This incident affected: Admin Panel.