Community Page Not Loading
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 18:02 EDT
Investigating
We have identified an issue preventing Community pages from loading properly for creators and their students. Our team is in the process of deploying a fix and expect this to be resolved shortly. We apologize for the inconvenience and thank you for your patience.
Posted Apr 24, 2024 - 17:06 EDT
This incident affected: Student Experience (Community).