Students are unable to access course curriculum overview page on the web
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted May 31, 2024 - 07:08 EDT
Update
We are continuing to investigate this issue. Course remain available to students via the iOS application.
Posted May 31, 2024 - 06:58 EDT
Investigating
We are currently investigating this issue.
Posted May 31, 2024 - 06:55 EDT