Issues loading some PDF files

Incident Report for Teachable

Resolved

Our team has resolved an issue with loading PDF files. During that timeframe, users would have not been able to view PDFs as students or creators. We apologize for the disruption and thank you for your patience.
Posted Jul 09, 2025 - 12:48 EDT

Identified

The team has identified an issue impacting the URLs for PDF files resulting in those files being temporarily inaccessible. We're working as quickly as possible to understand the root cause to resolve the issue. Thank you for your patience and understanding.
Posted Jul 09, 2025 - 11:34 EDT