Teachable Platform Outage

Incident Report for Teachable

Resolved

Our team has resolved the issue where users were unable to access the platform. We apologize for the disruption and thank you for your patience.
Posted Feb 10, 2026 - 15:07 EST

Monitoring

The platform access issue has resolved, and we're currently monitoring the results to ensure everything is working as expected. Thank you for your patience.
Posted Feb 10, 2026 - 14:39 EST

Investigating

Our team has identified an issue resulting in the inability to access the Teachable platform for both creators and students. We understand the critical urgency of resolving this issue and we apologize for the inconvenience. Thank you for your patience, and please check back here for an update shortly.
Posted Feb 10, 2026 - 14:27 EST