Some admin users are experiencing issues viewing and uploading course content
Incident Report for Teachable
Resolved
This incident has been resolved. We apologize for the inconvenience and thank you for your patience.
Posted Dec 05, 2024 - 15:17 EST
Monitoring
The issue appears resolved; however, our team is still continuing to monitor. We apologize for the inconvenience and thank you for your patience.
Posted Dec 05, 2024 - 14:09 EST
Investigating
We’re investigating an issue preventing some admin users from viewing and uploading course curriculum content. This is not impacting students' ability to view and consume course content. Our team is actively working to resolve this issue as quickly as possible. We apologize for the inconvenience and thank you for your patience.
Posted Dec 05, 2024 - 10:01 EST
This incident affected: Managing your School (Course Building).