Unusually High Processing Queue

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted Mar 02, 2024 - 20:46 EST

Investigating

We're actively investigating an issue with our asynchronous jobs, causing delays in various areas of the platform, particularly user updates and emails. We expect that all jobs initiated during this latency will process as the queue clears.
Posted Mar 02, 2024 - 20:02 EST