Some student subscriptions not charged

Incident Report for Teachable

Update

We've resolved the remaining issues impacting these subscriptions and will process the subscriptions over the next 24 hours.
Posted Mar 04, 2026 - 17:31 EST

Monitoring

Approximately 50% of the impacted subscriptions have been processed successfully, and we're continuing to work on the remaining subscriptions. We'll post a further update as soon as all subscriptions have been processed.
Posted Mar 04, 2026 - 16:05 EST