Memberships Outage
Incident Report for Teachable
Resolved
We have resolved the issue of students not seeing their membership experience. All systems functional again. We apologize for the inconvenience
Posted Mar 28, 2024 - 17:29 EDT
Monitoring
Students are able to access their memberships again. We will be monitoring further to ensure all functionality is restored.
Posted Mar 28, 2024 - 13:09 EDT
Investigating
We are currently investigating a bug that is preventing access to Memberships functionality. We believe we have identified the root cause and are working on a fix.
Posted Mar 28, 2024 - 10:29 EDT
This incident affected: teachable.com and Managing your School (Memberships).