Intermittent failure loading lecture details in mobile app

Incident Report for Teachable

Resolved

Our team has resolved an issue resulting in [ex: widespread platform outages] that lasted 4 hours. During that timeframe, users would have experienced intermittent disruption when using the Teachable mobile app. We apologize for the disruption and thank you for your patience.
Posted Apr 24, 2026 - 16:38 EDT

Monitoring

A fix has been deployed. We’ll continue monitoring to ensure everything is working as expected. We apologize for any inconvenience and appreciate your patience.
Posted Apr 24, 2026 - 16:03 EDT

Identified

The issue has been identified and our team is in the process of deploying a fix and expect this to be resolved shortly. We apologize for the inconvenience and thank you for your patience.
Posted Apr 24, 2026 - 15:13 EDT