Investigating 504 errors
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Jan 27, 2020 - 11:38 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2020 - 10:41 EST
Investigating
We are seeing an increased amount of errors to our student facing pages. We are investigating the issue.

We will provide an update as soon as there's additional information available.
Posted Jan 27, 2020 - 10:18 EST
This incident affected: Student View.