Intermittent Checkout Errors
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted May 11, 2020 - 13:21 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2020 - 13:09 EDT
Investigating
We are currently investigating this issue.
Posted May 11, 2020 - 12:41 EDT
This incident affected: Checking Out / Payment Processing.