Course curriculum not display correctly for students

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 16:49 EST

Update

Investigating - Our team has identified an issue with course and curriculum pages. We understand the urgency of resolving this issue and we apologize for the inconvenience. Thank you for your patience, and please check back here for updates.
Posted Feb 24, 2026 - 08:55 EST

Investigating

We are currently investigating this issue.
Posted Feb 24, 2026 - 08:55 EST
This incident affected: Student Experience (Content Delivery).