Latency with Background Jobs

Incident Report for Teachable

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 14:00 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2026 - 12:46 EST

Identified

Our team has identified an issue leading to high latency in background jobs across the platform. You may see some delays We are actively working to resolve this issue and deploy a fix as quickly as possible. We apologize for the inconvenience and thank you for your patience.
Posted Jan 23, 2026 - 12:41 EST