Course curriculum not displaying correctly for students

Incident Report for Teachable

Monitoring

We have determined that this issue may have resolved on its own or may not be widespread. We will continue to monitor and investigate for a root cause in the meantime.
Posted Feb 24, 2026 - 10:23 EST

Investigating

We are still investigating this issue.
Posted Feb 24, 2026 - 09:58 EST