Video loading issue in Chrome for schools with a custom domain

Incident Report for Teachable

Resolved

After further investigation, we’ve confirmed that this video loading issue in Chrome only affected a single school using a custom domain. No broader platform impact was identified. Thank you for your patience.
Posted Jun 25, 2025 - 12:32 EDT

Investigating

We've identified an issue preventing Teachable schools with a custom domain from loading videos in Chrome for creators and their students. We understand the critical urgency of resolving this issue and we apologize for the inconvenience. Thank you for your patience, and please check back here for an update shortly.
Posted Jun 25, 2025 - 12:02 EDT
This incident affected: Student Experience (Video Playback).