Users may be unable to access checkout pages and login to individual schools
Incident Report for Teachable
Resolved
Monitoring has confirmed that the issue is fully resolved. The platform is stable, and all systems are operating normally. Thank you for your patience as we worked to address this.
Posted Sep 26, 2024 - 14:02 EDT
Monitoring
We have identified the root cause of the issue, and it is currently being resolved. Our team is actively monitoring the situation to ensure full recovery and stability. We will provide further updates as we confirm progress.
Posted Sep 26, 2024 - 13:37 EDT
Investigating
We are currently experiencing a service disruption with login and access to individual school checkout pages. Our team is working to identify the root cause and implement a solution.
Posted Sep 26, 2024 - 13:15 EDT
This incident affected: Account (Log In), Student Experience (Checkout), and teachable.com.