Issue accessing student facing media

Incident Report for Teachable

Resolved

Our team has resolved an issue with images, videos, and other media not loading in the student experience. During that timeframe, users would have not been able to view images or videos as students. We apologize for the disruption and thank you for your patience.
Posted Aug 04, 2025 - 11:11 EDT

Identified

The team has identified an issue with images, videos, and other media not loading or resulting in errors displayed for the student experience. The team is working as quickly as possible to investigate and resolve the issue.
Posted Aug 04, 2025 - 10:59 EDT