All sites down
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Nov 23, 2019 - 02:08 EST
Monitoring
Sites are back up, we are continuing to monitor the situation closely.
Posted Nov 23, 2019 - 01:57 EST
Investigating
All teachable sites are currently down, we are investigating the issue.
Posted Nov 23, 2019 - 01:47 EST
This incident affected: Checking Out / Payment Processing, Student View, and Admin Panel.