Some student subscriptions not charged

Incident Report for Teachable

Monitoring

Our team has identified the problem that caused this issue, and all impacted subscriptions should be charged successfully by the morning of March 4th. We'll continue monitoring to ensure these payments are processed correctly, and we apologize for the delay.
Posted Mar 02, 2026 - 10:49 EST

Investigating

The team is aware that a number of student subscriptions that were scheduled to be processed on February 28th, 2026 were not charged. We are currently investigating this issue.
Posted Mar 02, 2026 - 09:58 EST