Admins will be unable to upload media content in select products
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted Sep 16, 2021 - 12:04 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 16, 2021 - 11:12 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 16, 2021 - 08:54 EDT
This incident affected: Styling your School (Theme Settings) and Video Uploading.